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1.DESCRIPTION 
The CYBERQII is one of the most advanced BBQ controls on the planet.  It is called the CYBERQII 

because it can be used to control two pits simultaneously.  You can access it using this Control Interface 

through cyber space from any remote location, or use it locally with your PC.   

 

 

2.CyberQII  and Control Interface - USB, Network and Operating System 

Compatibility, Features and Limitations 

2.1.USB 

The CYBERQIIôs USB interface is like that of a digital camera, in that it requires a PC to send and 

receive data.  It cannot be directly connected to a router and accessed over a network or the internet, due 

to the limitations of USB and its protocols.  It is not a web server.  It does not have an IP address.  It is a 

slave USB device.  The CyberQII uses the USB CDC ACM (universal serial bus communications device 

class abstract control model) protocol, which emulates a virtual communications port on the PC.  This 

interface was chosen to facilitate the ease of user development and maintenance of the PC application 

source code. 

2.2.Networkability 

Remote Desktop - The CyberQII Control interface can be accessed using remote desktop applications 

via another PC or a cel phone that resides on the same network as the PC that the CyberQII is connected 

to.  The remote desktop feature in Windows Xp Professional must be turned on to do this.  Setup for 

remote desktop on the iphone is described in this user guide.  Some versions of Vista also support 

remote desktop and there are many articles on the web that describe how to accomplish this.  There are 

also USB over network and USB over internet applications that are described in the user guide. 

2.3.Operating Systems 

The CyberQII control interface can be installed and will run on Windows Xp or Windows Vista PCs.  

You can directly connect the CyberQIIôs USB interface to a Windows Xp PC, and to Vista PCôs under 

certain conditions.  Windows Xp has been proven in our tests to provide a more reliable USB connection 

to the CyberQII. 

2.4. BBQ GURU CYBERQII CONTROL INTERFACE FEATURES 

 Provides a single Dashboard display.  This graphical, easy-to-read display of all the controlôs 

measurements and setpoints are shown on one screen of your laptop or computer when 

connected to the CYBERQII control. 

 Exports Chart Data to Excel. 

 Allows you to monitor and even make adjustments to all setpoints and all other settable values 

from a remote location, enabling you to control your cook even while away from the cook site. 

 Real-time graphing of all of the temperature sensors and fan outputs. 

 More than one control unit can be monitored by opening corresponding numbers of Control 

Interface instances. 

 Open Source Code in C#.NET and the project file for Microsoft Visual studio is available free of 

charge to experienced programmers for limited, non-commercial use.  Contact theBBQGuru.com 

for more details. 
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3.INSTALLING THE CYBERQII CONTROL INTERFACE ON YOUR 

COMPUTER FROM A CDROM PROVIDED BY THE BBQ GURU  
System Requirements: 

 Computer with: 

1. Windows XP, SP2 or later, Windows Vista 32 and 64 Bit with .NET Framework V3.5 

2. a USB port 

3. CD ROM /DVD Drive 

4. a screen resolution capable of 1024 x 600 or better 

5. Internet Connection (to download Microsoft .NET framework if needed) 

 USB cable 

 CyberQII Controller 

 CyberQII Control Interface Install CD 

3.1. Quick Startup Guide for use with CDROM installation 
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4.INSTALLING THE CYBERQII CONTROL INTERFACE ON YOUR 

COMPUTER FROM AN EMAI LED UPDATE FROM THE BBQ GURU  
System Requirements: 

 Computer with: 

1. Windows XP SP2 or later 

2. a USB port 

3. CD ROM /DVD Drive 

4. a screen resolution capable of 1024 x 600 or better 
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5. Internet Connection (to download Microsoft .NET framework if needed) 

 USB cable 

 CyberQII Controller 

 

Installation will be done in 4 phases: 

1. Copying the install software to your desktop 

2. Installation of the Microsoft .NET Framework (if your computer doesnôt already have it) 

3. Installation of the CyberQII Control Interface PC Application 

4. Installation of the CyberQII Control Unit Hardware 

 

We will go through these steps in detail in the following four sections. 

 

If you received a CD ROM of the Setup files, insert the CYBERQII Control Interface Do not use 

this setup procedure.  Follow the Quick start guide provided on the CYBERQII install CD. 

4.1.Copying the install software to your Desktop 

 

If you received a CD ROM of the Setup files, Do not use this setup procedure.  Follow the Quick 

start guide provided on the CYBERQII install CD. 

 

If you downloaded the Setup files, copy the install setup.zip file to your desktop. 

 

If windows shows that the file is blocked, right click the setup file to open the file properties and 

click on Unblock. 

 

Double Click the zipped setup folder and your screen will show: 

 
 

Click Extract All Files, then double click the new folder and your screen will show: 
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4.2. Installation of the Microsoft .NET Framework (if your computer doesnôt already 

have it) 

 

Please have your computer turned on and an internet connection available.   

 

Double click Setup.  If you computer doesnôt have the .NET Framework, windows will go to the 

MSDN website and download it.  If you already have it, skip this section. 

 

Windows will ask your permission to download the .NET Framework: 

 
 

 

Click Yes and Windows will go to the web and show: 
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Click Install It Now; your screen will show: 

 
 

 

Click Run and your screen may show: 

 
 

 

Click Run and your screen will show: 
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And then: 

 
 

Select ñI have read..ò, click Install and your screen will show: 
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When download is complete your screen will show: 
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Click Exit and your screen will show: 

 
 

Click Restart Now. 

 

4.3. Installation of the CyberQII Control Interface PC application 

Double click the Setup folder on your desktop and your screen will show: 
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Double click Setup and your screen will show: 

 
 

 

Click Next and your screen will show: 
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Click next and your screen will show: 

 
 

 

Once the installation is complete your screen will show: 
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Click Close. 

 

4.4. Installation of the CyberQII Control Unit Hardware 

Attach the small end of the USB cable to your CyberQII and plug the large end into a USB2.0 compliant 

port on your computer then apply power to the CyberQII controller.  You should hear two tones (low 

then high) on your PC to confirm connect.  If you hear three tones of the same pitch or see a 

ñUnregognized Device Errorò this means a bad connection.  Do not unplug and replug the USB 

connector, press the power key on the Cyber QII to power down and then press it again to power back 

up.  If you cannot get a good connection see the Troubleshooting USB Connections section of this 

document. 

 

Once connected, a found new hardware dialogue box will appear at the bottom right: 
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Then your screen will show the Found New hardware Wizard: 

 
Select ñNo, not this timeò and click Next. 

 

 

The second Found New hardware Wizard screen will then appear: 
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Select ñInstall from a list...ò and click Next: 

 

 

The third Found New hardware Wizard screen will then appear: 

 
Browse to ñC:\Program Files\The BBQ Guru\CYBER QII Control Interface\ò: 

 

 

Click Next and your screen may show the hardware installation box confirming verification: 
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The fourth Found New hardware Wizard screen will then appear: 

 
 

The fifth Found New hardware Wizard screen will then appear: 
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Click Finish. 

 

Congratulations!  The Cyber QII is now completely setup on your PC! 

 

5.INSTALLING A N UPDATED VERSION OF THECYBERQII CONTROL 

INTERFACE  
Before installing a new version of the CyberQII Control Interface you must first uninstall the old 

version:   

 

Click Start > Control Panel > Add or remove Programs > CyberQII Control Interface > Remove 
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Select Cyber QII Control Interface and Click Remove. 

 

The Cyber QII Control Interface is now removed and can be updated or reinstalled. 

 

Now you may install the new version per the instructions in the previous sections of this document. 

 

6.CONNECTING YOUR CYBERQII TO YOUR LAPTOP/COMPUTER  
There are five different ways this user guide will show you how to connect your CyberQII and a PC: 

 Direct USB Connection to a PC (Difficulty: EASY). 

 Connection using a USB extension cable to a PC (Difficulty: EASY). 

 Connection using a Wireless USB Hub (Difficulty: AVERAGE).  

 Connection via USB over wireless or wired network (Difficulty: MODERATE) 

 Connection via USB over the Internet (Difficulty: ADVANCED). 

6.1. Direct USB Connection to a PC 
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System Requirements: 

 Laptop, netbook or any computer with: 

1. Windows XP 

2. USB 2.0 port 

 USB cable 

 CyberQII 

 

To use the Dashboard to monitor/manage your cook(s) using your computer, connect it as follows.   

 

Note:  For all other CYBERQII connections, please refer to the Controller Connections section of the 

CYBERQII User Guide. 

 

 Plug the small end of the USB connector into the leftmost port on the CYBERQII, then large end 

of the cable into your laptop/computer.  Then apply power to the CyberQII.  You should hear 

two tones (low then high) on your PC to confirm connect.  If you hear three tones of the same 

pitch, this means a bad connection.  Do not unplug and replug the USB connector, press the 

power key on the Cyber QII to power down and then press it again to power back up.  If you 

cannot get a good connection see the Troubleshooting USB Connections section of this 

document. 

 Open the CYBERQII Control Interface application.   

 Pressing the ON / OFF    key on the CYBERQII unit will power up/down the control and 

will disconnect the USB link.   

 

6.2. Connection Using a USB Extension Cable to a PC 

 

 
 

If you want to extend the range of your USB connection, there are many manufacturers such as BAFO 

Technologies making USB extension cables.  Simple connect the extension cable to your computer, and 

connect the other end to the free end of the USB cable that is connected to your CYBERQII.  You may 

be able to add multiple extension cables; consult the extension cable manufacturerôs instructions and 

specifications.  Because the configuration has changed, you will need to repeat the steps in the section 

entitled ñInstallation of the CyberQII Control Unit Hardwareò.  You will only have to do this setup once 

for this configuration. 

6.3. Connection Using a Wireless USB Hub 
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If you want to extend the range of your USB connection over a short range without wires, there are 

many manufacturers making USB wireless hubs such as IOGEAR and the Dlink DUB-9240.  Follow the 

manufacturerôs installation instructions before installing, as some of these types of devices require 

software drivers.  Once the wireless key and hub are properly installed, simply connect the wireless USB 

key to the pc, and plug the USB cable connected to the CYBERQII into the hub.  You may be able to 

add extension cables to this if desired.  Because the configuration has changed, you will need to repeat 

the steps in section entitled ñInstallation of the CyberQII Control Unit Hardwareò.  You will only have 

to do this setup once for this configuration.   

 

NOTE: All wireless systems are susceptible to interference.  Cordless phones and wireless routers are 

the biggest causes of interference for wireless computer devices. 

 

 

6.4. Connection Via USB Over Wireless or Wired Network 

Local PC

Network PC

Wireless Router

 
 

If you would like to have the CyberQII plugged into a local PC like a notebook and run the CyberQII 

Control Interface software on a Network PC you will need a piece of software that is available from 

many companies (such as Fabula Tech) called a USB Over Network.  You simply setup the local PC 

above to be the server and the Network PC to be the client.  The Nework PC will then have direct access 

to the data on the Local PCôs USB port.  Just follow the installation instructions provided with whatever 

software you choose.  The setup takes about 10 minutes and is a very reliable way to setup a remote 

connection to the CyberQII. 
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6.5. Connection Via USB Over the Internet 

 
 

 

If you would like to have the CyberQII plugged into a local PC and run the CyberQII Control Interface 

software on a remote PC  via the internet, you will need a piece of software that is available from many 

companies, such as Fabula Tech, called a USB Over Network.  You simply setup the local PC above to 

be the server and the Network PC to be the client.  The remote PC will then have direct access to the 

data on the local PCs USB port.  Just follow the installation instructions provided with whatever 

software you choose. 

 

Another solution to running your CYBERQII remotely is a PC Anywhere type solution.  With this type 

of solution, the CYBERQII software is actually running on the local pc and the remote pc has access to 

change anything on the local PC. 

6.6. Controlling the CYBERQII from your iphone 

With the iPhone you can access the PC that has XP Professional installed.   

 

Download mocha soft iphone application  http://www.mochasoft.dk/ for free (for now) into I tunes and 

download it to your iphone. 

  

If you havenôt already, install the CyberQ software on a PC that has XP Pro.   (XP Pro is required for 

most remote desktop apps, so you may want to upgrade to XP pro if you do not have it.)  

  

Go to control panel -> system ->remote tab. 

  

In the remote tab check "Allow remote users to connect to this PC remotely" 

  

Open the mochasoft iphone application. 

  

On the iphone tap connect (at the upper right).  Set the ip address for the PC with the CyberQ 

application on it.  (go to ms dos prompt and type ipconfig/all; this will tell you the local ip address of the 

PC with the Cyber App on it).  Enter your user name and password for the PC.  If you donôt have a 

password setup on your PC you will get the Error Message: ñUnable to Log You on Because of an 

Account Restrictionò.  In that case, follow Microsoftôs  bulleten:  

http://support.microsoft.com/kb/303846 

  

Using the mochasoft iphone app, you should be able to successfully log in to your PC and control 

CyberQII control interface from your iphone.  It shows all of the charting and sliders, and you can make 

adjustments.   

 

http://www.mochasoft.dk/
http://support.microsoft.com/kb/303846
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6.7. Troubleshooting USB Connections 

6.7.1. Troubleshooting a ñUSB Problemò or ñCyberQ not found on USB portò error in the 

CyberQII Control Interface 

1. Make sure that the Cyber Q II is plugged into your USB port properly . 

2. Make sure you have installed the USB drivers properly by consulting the ñQuick Startup Guide 
for use with CDROM installationò section of this document. 

3. Consult the 3 sections ñThe proper sequence for connecting your CYBERQ2 to a PCò, 

ñTroubleshooting a ñUSB device not recognizedò  messageò and ñTroubleshooting a ñDevice 

Cannot Start - Error Code 10ò messages (advanced)ò 

4. If the CyberQII is enumerated on the USB port and shows up as a com port in device manager 

and device manager says it is working correctly, then you may have a conflict with other com 

ports on your PC.  Consult the ñConfigure Com Portò section of this document. 

6.7.2. The proper sequence for connecting your CYBERQ2 to a PC 

1. Plug the small end of the USB connector into the leftmost port on the CYBERQII, then large end 

of the cable into your laptop/computer.   

2. Then apply power to the CyberQII.  You should hear two tones (low then high) on your PC to 

confirm connect.   

3. If you hear three tones of the same pitch, this means a bad connection.  Do not unplug and replug 

the USB connector, press the power key on the Cyber QII to power down and then press it again 

to power back up.  If you cannot get a good connection see the sections below: 

6.7.3. Troubleshooting a ñUSB device not recognizedò  message 

1. If you get a unregonized device error, do not unplug and replug the USB connector, press the 

power key on the Cyber QII to power down and then press it again to power back up.  Try this 

several times.   

2. If you still cannot get a good connection, eliminate any USB hubs from the link, and make sure 

that the USB connectors are inserted completely on the PC and the CYBERQII.  Press the power 

key on the Cyber QII to power down and then press it again to power back up.   

3. If you still cannot get a good connection and are using a notebook, try disconnecting the charger 

from the notebook (it may be causing interference).    Press the power key on the Cyber QII to 

power down and then press it again to power back up. 

4. If you still cannot get a good connection and are using a notebook, try turning off your wireless 

internet connection (it may be causing interference).  Press the power key on the Cyber QII to 

power down and then press it again to power back up.   

5. If you still cannot get a good connection, try replacing the USB cable.  Press the power key on 

the Cyber QII to power down and then press it again to power back up. 

6. If you still cannot get a good connection, try the suggestions in the next section.   

6.7.4. Troubleshooting a ñDevice Cannot Start - Error Code 10ò messages (advanced) 

 

If you havent been able to get a good connection to the CyberQII: 

1. Open Device Manager is open, and select the CyberQII (Communications Port) that has the 

Problem. You can perform some recommended resolutions through Device Manager.  

a. Right-click My Computer , and then click Properties.  

b. Select the Hardware tab, and then click Device Manager.  
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c. Double-click the Ports (COMM&L PT) type that has the problem. It will appear as a 

Communications Port (COM XX). 

If there is a problem with the CyberQII, it will have a red exclamation point next to it. If 

a device is unknown (usually because of missing drivers or a startup problem), the device 

has a yellow question mark next to it.  

d. Right-click the CyberQII that has the problem, and then click Properties. This opens the 

device Properties dialog box. You can see the error code in the Device status area of this 

dialog box. 

e. From here you can reinstall the drivers or delete and reinstall the Communications Port 

per the ñInstallation of the CyberQII Control Unit Hardwareò Section of this document. 

f. If you still cannot get a good connection try the suggestions in the previos section ï 

ñTroubleshooting an Unrecognized Deviceò Error. 

 

7.THE DASHBOARD 
The Dashboard provides a single-screen display of every menu on the CYBERQII unit, plus a real-time 

temperature graph. 

 

With the probes connected and the CYBERQII unit powered on and connected to the computer, you will 

be able to use the Dashboard to easily monitor and control your cook(s).  

 

Below is an example screen.   
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7.1.Resizing the Dashboard 

The Dashboard is designed to start up with a 1024 x 600 size window, which is compatible with most 

netbook PC screens.  You can make it larger or smaller by dragging the margins or corners. 
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8.PARAMETERS DISPLAY  

8.1.Pit Parameters 

Beginning with Pit 1 (shown below highlighted in gray), all parameters for both pits are displayed across 

the top.  

 

 
 

From left to right they are: 

 Actual temperature of  Pit 1 

 Actual temperature of Food 1 (food in Pit 1) 

 Actual temperature of Pit 2 

 Actual temperature of Food 2 (food in Pit 2) 

 Percentage run of Pit 1 fan 

 Percentage run of Pit 2 fan 

 

9.ALARM MESSAGES  
Alarm messages will be displayed in the bar across the top of the application in red. 

 

Please refer to the Status Screens section of The BBQ Guru CYBERQII User Guide for a detailed 

description of all possible messages.  A corresponding message will be displayed on the bar across the 

top shown below. 
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9.1.ALARM BEEPING 

To enable the PC alarm beeping see the Configuring Alarm Beeping Section of this document.  If the 

alarm beeping is enabled and a new alarm is present, the PC will beep every second.  To ñsilenceò the 

alarm, click the stop alarm button next to the disconnect button.   
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10.PIT 1 ATTRIBUTES  
All of the attributes for Pit 1 will be displayed in this section (highlighted below in gray). 

 

 
 

This section allows you to set all values for Pit 1.  You can use the Dashboard to set these values; simply 

use the slider bars or checkboxes.  Please refer to the following table to access detailed information 

about the usage of each of these as they correspond to the CYBERQII unit User Guide.   

 

Please note that when using the Dashboard to set values, the values may take several seconds to update. 

 

PIT 1 ATTRIBUTE:  REFER TO SECTION OF CYBERQII USER GUIDE:  

Food 1 Setpoint Food 1 Set Screen 

Pit 1 Setpoint Pit 1 Set Screen 

Pit 1 Hold Pit 1 Hold Set Screen 

Cook Timer 1 Timer 1 Set Screen 

Timeout Timeout Action 1 Set Screen 

Alarm 1 Alarms 1 Set Screen 

Ramp 1 Ramp 1 Set Screen 

Open Lid 1 Open Lid Detect 1 Set Screen 
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11.PIT 2 ATTRIBUTES  
All of the attributes for Pit 2 will be displayed in this section (highlighted below in gray). 

 

 
 

This section allows you to set all values for Pit 2, if you are running a second cook.   

 

These values correspond exactly to those described in the Pit 1 Attributes section described above.  

Please refer to that section for information on setting these values for Pit 2. 

 

Please note that when using the Dashboard to set values, the values may take several seconds to update. 

 

12.CONTROL SETUP 
All parameters for the setup of the CYBERQII will be displayed under the Control Setup section 

(highlighted in gray below). 
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12.1. Battery Power, Alarm Beeps, Back Light 

For detailed information on the Battery Power, Alarm Beeps, and Back Light settings, please refer to the 

Battery, Backlight, Beeper and Display Setup section of the CYBERQII User Guide.  To set the values 

using the Dashboard Control Interface, use the slider bars. 

12.2. Proportional, Ramp OffSet, Cycle Time, Alarm Deviation, Temp Units 

For detailed information on the Proportional, Ramp OffSet, Cycle Time, Alarm Deviation and Temp 

Units settings, please refer to the Super User section of the CYBERQII User Guide. To set the values 

using the Dashboard Control Interface, use the slider bars, and button for Temp Units. 

 

13.THE PIT AND FOOD TEMPERATURE GRAPH  
The line graph charts the temperature plots and is always displayed in the bottom left corner (see bottom 

left below).   

 

The graph is a very handy feature to monitor your cook easily.  Updated in real-time, it charts the 

changes in temperature of your pit(s) and food. 

 

The graph is customizable.  You can choose which parameters to chart (please refer to the Chart 

Attributes section of this document). 
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14.Connecting, Disconnecting and Exiting the Application 

14.1.Connecting 

To establish a connection between the CYBERQII unit and the Control Interface, click File > Connect.  

You can also click the red ñConnectò indicator at the top left (shown below as Disconnect because the 

Control Interface is currently connected.)  The Control interface will make automatic attempts to 

reconnecting to the control if it becomes disconnected. 
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Once the unit is connected to the PC with the USB cable, the ñDisconnectò indicator will be displayed in 

red at the top left of the application. 

14.2.Disconnecting 

To disconnect the CYBERQII unit from the PC, click File > Disconnect.  You can also click the red 

ñDisconnectò indicator at the top left (see below). 
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14.3.Exiting the Application 

To exit the application, click File > Exit.  You can also click the standard Windows red X at the top right 

of the Control Interface window. 
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15.Viewing Key Indicators and the Chart  

15.1.Key Indicators Only 

To open a new window to display just the key indicators, click View > Key Indicators Only.  You can 

also press F1.  It will display your alarms and key attributes for each pit in large text format. 
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Key Indicators Only screen: 

 


